Select Page

FlyWithLua NG for X-Plane 12+

UPDATE Our date September 29th, 2022:
Official FlyWithLua NG+ (Next Generation) X-Plane 12 version 2.8.0

This is the official NG+ (Next Generation Plus) Edition of FlyWithLua for X-Plane 12. Going forward NG+ will be the only developed FlyWithLua version. Support will generally be a community effort.

Something is going wrong?
Carefully read the Log.txt file and let FlyWithLua write a debug file, if one of your scripts fails. If you want to ask for help, please use the FlyWithLua help forum and add your Log.txt and FlyWithLua_debug.txt files.

For any help click here –> http://forums.x-plane.org/index.php?/forums/forum/335-help-me-i-have-a-problem-with-flywithlua/

If you are using the Complete Edition, you will get help from the community. I will not support this version, but a good qualified question typically gets an answer in a few hours. So don’t be shy to ask (after searching for your issue fails).

What is FlyWithLua?
FlyWithLua offers a rapid development system to get in deep into X-Plane. An easy to understand, detailed manual is included.

FlyWithLua will support all platforms, Windows, Linux and Mac, and it will support X-Plane 9 and X-Plane 10. A script can be used on all platforms by default, without the need of re-editing. This let’s you share scripts with friends using other systems.

FlyWithLua uses LuaJIT as a compiler. This results in very fast code execution, much faster than the original Lua interpreter. FlyWithLua is ready to be used by anybody, no matter if you are a beginner or an experienced Lua developer.

First time downloading FlyWithLua?
FlyWithLua isn’t freeware, it’s “timeware”!
You will have to read at least the basic installation instruction here inside the official FlyWithLua support forum. FlyWithLua was made in a couple of years for me as the creator and main developer, and also many many hours of building, testing and answering support questions to my co-authors Snagar and Sparker and some more volunteers helping this project to exist. So please have the appreciation to carefully read and understand some information about FlyWithLua – to avoid frustration to you and the developer team.

Enjoy this plugin. I choose the MIT Licence for it’s core and all additional libraries are freeware (please see individual licence), so it’s totally free to use.

Linux Users
You will need to install these two libraries using this command.

sudo apt-get install -y freeglut3 libopenal1

Updated download so Linux will look in Resources/dlls/64 for libfmod.so.13 and libfmodstudio.so.13. If you are using a distro older that Ubuntu 22.04 please do the following. In the 64 folder rename lin.xpl to lin.xpl_bak. Next rename older_distro_lin.xpl to lin.xpl. OpenAL will only play stereo sounds.

I have been looking for a solution but not found one yet but found this workaround.

sox 10ft.wav 10ft_stereo.wav channels 2
Fmod will play both and many more types.

Note:
This package is offered to you by X-Plained.Com. It is free for personal and/or private use. It is not allowed to copy, publish or redistribute any part of any file or package from this website without prior permission from X-Plained.Com or from the developer. Commercial use of the package or parts of it, is prohibited in any way.
Keep in mind that your maximum download per day is set to 15 files or packages a day.

 

FlyWithLua NG Plus (0.0 B, 77 downloads)